dust storm

Incident Report for blue

Resolved

back online
Posted May 16, 2025 - 19:03 CDT

Monitoring

a dust storm will impact the server by 6:45PM CENTRAL TIME. please allow us to keep our server off duing this period to prevent data loss.
Posted May 16, 2025 - 18:47 CDT
This incident affected: website, flash uploading service, wap homepage, and search engine.